Digital transformation fights
During digital transformation the biggest challenge is to convince people to change their current processes. Arguments are inevitable, after all you are inventing a new process. How to deal with emotions that will always accompany your transformation efforts?
Symptoms
it is hard to propose a process that everyone would be happy with
process owners spend lot of time traveling to various locations to organize workshops
during some of the meetings people shout and leave slamming the doors
Negative results
adoption of the new processes may be unsuccessful
moths spend trying to resolve arguments
leadership is blamed for all the problems
Causes
different parts of organisation are working in different ways
everyone wants to keep their current ways of working
legacy systems require certain ways of working
This is my advice
Steps to perform
split digital transformation into areas and agree these areas with all departments to get their buy-in
create a list of responsibilities which make up certain area
create a list of tasks which are necessary to fulfill certain responsibility
invent together a business process for each such task using Task Description best practices
Positive results
work on transformation is transparent and focused on results
building agreement over ideal business processes
same standard way for analysis of every area which is proven in other organisations - case study in medical industry
Challenges
the need to adapt new, little known technique of Task Descriptions - take a training
imposing discipline during meetings
The benefits of not changing anything
same people may continue to work on solving process issues without distraction
lack of consulting costs - first time creation of Task Descriptions is much simpler with help of experienced Requirements Engineer